5个月前 (01-19)  技术资料 |   抢沙发  4 
文章评分 0 次,平均分 0.0

关于VC++6.0这个软件不兼容win10/win8/8.1等新系统的问题,网上需要解决的的朋友是越来越多了,因为VC++6.0是一个比较老的程序编译软件,win10/win8/8.1是比较新的系统,对于老软件的兼容性不是很好,但是大学里学习C/C++编程的时候,老师们都喜欢用这个软件,这就使得喜欢使用新系统的同学犯愁了,无法在win10/win8/8.1系统上完美运行VC++6.0编译器,不过不用灰心,只要想想办法,动动手,这个兼容性问题还是比较容易解决的,下面亦是美网络就教给大家让VC++6.0编译器完美支持win10/win8/8.1系统的方法。

安装过程很简单,一步一步按照提示操作就可以了,本文着重给大家讲兼容性设置。

Visual C++ 6.0 在win10/win8/8.1系统上的兼容性设置

a、关于兼容性设置其实也很简单,我们首先找到vc++6.0的安装目录,在安装目录里找到“MSDEV.EXE”这个文件,然后选中这个文件,点击右键,选择“属性”,打开如下窗口:

解决win10、win8系统不兼容Visual C++6.0编译器的问题

将图中标注的地方的MSDEV修改为MSDEV16。

b、然后在这个界面切换到“兼容性”选项卡,如下图所示:

解决win10、win8系统不兼容Visual C++6.0编译器的问题

在兼容模式那里勾选“以兼容模式运行这个程序”,并选中“Windows XP (Sevice Pack 3)”;

然后在下面勾选“以管理员身份运行此程序”,完成后点击“确定”,使保存生效即可。

c、在桌面上找到Visual C++ 6.0的快捷方式,然后右键 - 属性,打开后切换到“快捷方式”选项卡,如下图所示:

解决win10、win8系统不兼容Visual C++6.0编译器的问题

将图中标注的“目标”后面的路径,把MSDEV.EXE修改成MSDEV16.EXE,确定即可。

经过这样一番设置,VC++6.0就可以完美运行在win8/8.1等新系统上了。

 

除特别注明外,本站所有文章均为安装打印机网原创,转载请注明出处来自https://www.azdyj.com/15727.html

发表评论

暂无评论

登录

忘记密码 ?

切换登录

注册